8??? needed this patch http://www.nvnews.net/vbulletin/showthread.php?t=62021 (first one in there) in order to be able to compile ("vmap()" issue, I think.). The error message is seen here: http://www.nvnews.net/vbulletin/showthread.php?t=66751

Working with Debian amd64

Debian's AMD64 distribution runs a pure 64 bit operating system. The Nvidia kernel installer doesn't know how to install it's files with this (I think the latest one does).

I think you could do something like this:

   1 cd /usr/X11R6
   2 ln -s lib lib64

, but I haven't tested it yet.

You could also move files after it installs. Here's how I did it. First, install it as normal. The installer puts files into /usr/X11R6/lib64, not /usr/X11R6/lib as it should for Debian. This script will fix it:

   1 cd /usr/X11R6/lib
   2 pwd
   3 ln -s -vi ../lib64/*.so* ../lib64/*.a .
   4 
   5 cd /usr/X11R6/lib/modules/extensions
   6 pwd,
   7 ln -s -vi ../../../lib64/modules/extensions/*.so* \
   8           . 
   9 cd /usr/X11R6/lib/modules/drivers
  10 pwd
  11 ln -s -vi ../../../lib64/modules/drivers/*.so* \                                
  12           ../../../lib64/modules/drivers/*.o* \

DebianNotes/NvidiaDriver (last edited 2008-03-10 01:38:53 by localhost)